レンタルサーバー 激安



Moodleを利用できる激安サーバー

MoodleはPHPでプログラミングされているんだ。だから、まずは契約したいレンタルサーバーがPHPに対応しているかどうかを確認しよう。

次に、MySQLかPostgreSQLに対応しているかの確認だ。Moodleのデータは、主にMySQLとPostgreSQLがサポート対象になっているからだ。

また、Moodleはバージョンによって動作環境が異なるんだ。例えば、バージョン1.6だとPHP5は使えなかったり、バージョン1.8だとユニコードが必須だったりする。

自分がインストールしたMoodleのバージョンや動作環境と、契約したいレンタルサーバーとの相性をしっかり確認しておくことが大切だよ。

ざっくりまとめると、PHPとMySQL対応のレンタルサーバーを探せばOKということになるね。以下にピックアップしてみたから参考にしてほしい。

【PHP5とMySQL5に対応】
お名前.com 、 ロリポップ 、 ハッスルサーバー。

【PHP4と5、およびMySQL4と5の両方に対応】
エックスサーバー。

【PHP4と5、およびMySQLとPostgreSQLに対応】
エクセリア 、 コアサーバー。

サーバーごとに機能や月額使用料、サポート対応にはかなりの開きがある。特にサポートは、電話対応OKなところから、メールのみの中〜上級者向けまでと様々だ。

必要な機能とランニングコスト、自分のPCスキルに適したサポート対応などを十分に考え合わせてレンタルするサーバーを決めよう。




激安レンタルサーバー比較

アイル ホスティングサービス



エックスサーバー



ハッスルサーバー



お名前.comレンタルサーバー



ロリポップ



さくらインターネット



コアサーバー